Font Size


Font Size


From: HiHoCoder MS April 2016: Font Size

描述

Steven loves reading book on his phone. The book he reads now consists of N paragraphs and the i-th paragraph contains ai characters.

Steven wants to make the characters easier to read, so he decides to increase the font size of characters. But the size of Steven’s phone screen is limited. Its width is W and height is H. As a result, if the font size of characters is S then it can only show ⌊W / S⌋ characters in a line and ⌊H / S⌋ lines in a page. (⌊x⌋ is the largest integer no more than x)

So here’s the question, if Steven wants to control the number of pages no more than P, what’s the maximum font size he can set? Note that paragraphs must start in a new line and there is no empty line between paragraphs.

输入

Input may contain multiple test cases.

The first line is an integer TASKS, representing the number of test cases.

For each test case, the first line contains four integers N, P, W and H, as described above.

The second line contains N integers a1, a2, … aN, indicating the number of characters in each paragraph.

For all test cases,

1 <= N <= 103,

1 <= W, H, ai <= 103,

1 <= P <= 106,

There is always a way to control the number of pages no more than P.

输出

For each testcase, output a line with an integer Ans, indicating the maximum font size Steven can set.

样例输入

1
2
3
4
5
2
1 10 4 3
10
2 10 4 3
10 10

样例输出

1
2
3
2

二分答案。

AC代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
#include <fstream>
#include <iostream>
#include <string>
#include <vector>
using namespace std;


int N, P, W, H;
int CharNum[1001];

int solve(int fs)
{

if (fs > W || fs > H)
{
return 1000001;
}
// fs 是字体大小
int cols = W / fs; //计算每一行有多少字
int totalLines = 0;

for (int i = 0; i < N; ++i) //计算每一段有多少行
{
int paragLines = CharNum[i] / cols;
if (CharNum[i] - paragLines * cols > 0)
paragLines += 1; // 多的那几个字另算一行
totalLines += paragLines;
}

int LinesPerPage = H / fs; // 一页有几行
int pages = totalLines / LinesPerPage;
if (totalLines - LinesPerPage * pages > 0)
pages += 1; // 多的几行算作一页
return pages;
}

int main(int argc, char** argv)
{

// 二分答案?
int TASKS = 0;
cin >> TASKS;

for (int i = 0; i < TASKS; ++i)
{
// input
cin >> N >> P >> W >> H;
for (int k = 0; k < 1001; ++k)
{
CharNum[k] = -1;
}
for (int j = 0; j < N; ++j)
{
cin >> CharNum[j];
}

int PS = 0;
int S = 1;
int mid = 0;
while (PS < S && mid != P)
{
mid = solve(S);
if (mid < P)
{
PS = S;
S *= 2;
}
else if (mid > P)
{
S = (S + PS) / 2;
}
}
cout << S << endl;
}

return 0;
}